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  Introduction


  — PageEdit: The visual XHTML Editor —


  Welcome to the PageEdit User Guide—completely updated for PageEdit 0.9.5.


  View What’s New for changes in recent releases.


  Download PageEdit from:


  
    	The Official PageEdit Website

  


  Help is available from other users and the developers of PageEdit at MobileRead:


  
    	PageEdit Forum @ MobileRead

  


  The PageEdit User Guide includes documentation that will help you get the best out of editing your XHTML files, including:


  
    	Installation: Installing PageEdit on Windows, MAC and Linux.


    	Running PageEdit: Running PageEdit from Sigil or as a stand-alone app.


    	User Interface: A complete description of the PageEdit user interface.


    	Contributing to PageEdit: How to support PageEdit.

  


  
    You can download the latest version of the PageEdit User Guide ebook in EPUB format.

  


  What’s New


  — New Features —


  The latest version of PageEdit contains bug fixes and new features.


  
    For a detailed list of all the change made to PageEdit, see the Changelog.

  


  Recent Major Changes in PageEdit include:


  
    	The ability to pass all xhtml files in the spine in Reading Order to PageEdit via opening the OPF. This allows quick file navigation via navigation menu and next and previous arrows keys.



    	An Edit vs Preview mode toggle button that will allow links among xhtmls files in the spine to be active and work (in Mode: Preview)



    	A QtMessage handler to create a debug log file controlled via a PAGEEDIT_DEBUG_LOGFILE environment setting, to simplify user bug issue feedback


  


  All the new features, along with all features and functionality, are of course described in this PageEdit User Guide.


  About PageEdit


  — General Information —


  PageEdit was originally designed as a replacement for the Book View feature found in older Sigil versions. However, it can also be used as a general purpose visual XHTML editor.


  This open-source and completely free software is written and supported entirely by volunteers. The PageEdit development team includes Doug Massay and Kevin Hendricks as co-lead developers and maintainers. Previous developers/authors include John Schember, Grant Drake and Dave Heiland. PageEdit is based on Sigil, which was originally created by Strahinja Markovic in 2009 and remains completely free to download and use. Support is also provided by other volunteers who contribute code, translations and helpful answers to user’s questions.


  Installation


  — Getting Started —


  You can download the latest version of PageEdit from the official PageEdit website and install it for your OS.


  Windows


  PageEdit is supported on Windows 7 and later.


  
    	Download PageEdit for Windows.

  


  Double-click the file to run the installer, e.g.:


  
    	PageEdit_0.9.5-Win_x64.exe

  


  It’ll extract a folder called PageEdit.


  Move that PageEdit folder to a location that you’ll remember. For example: C:\Program Files\PageEdit.


  macOS


  PageEdit is supported on macOS 10.9 (Mountain Lion) x64 bit Intel or later


  
    	Download PageEdit for macOS.

  


  Unpack the TXZ file and drag the PageEdit.app file to your Applications folder, e.g.


  
    	PageEdit.app-0.9.5-Mac.txz

  


  Linux


  A binary version of PageEdit is not available due to the number of versions of Linux.


  However, since the source code is freely available, you can build from source for your version of Linux. And due to the effort of many volunteers, there is most likely a pre-packaged version of PageEdit built for your Linux distribution available online:


  
    	Building PageEdit On Linux

  


  Running PageEdit


  — From Sigil and as a stand-alone app —


  You can configure Sigil to run PageEdit or use it as a stand-alone application.


  Configure Sigil to run PageEdit


  1. Download and install PageEdit.


  2. Open Sigil, and go to Edit > Preferences > General Settings. At the very bottom, you should see a box that says “Set your preferred alternative external xhtml editor.” (If the option is not present, your Sigil version doesn’t support PageEdit.)


  
    [image: a screenshot of the external editor text box]
  


  3. Click the Browse button, and locate the PageEdit folder.


  4. Select PageEdit.exe. You can then click the OK button and get back to Sigil.


  5. Now, at the very top of Sigil, you’ll see a little button that looks like a pencil writing on paper that will open up PageEdit. If you haven’t changed the default Sigil keyboard shortcuts, you can also press F2.


  
    [image: a screenshot of the PageEdit toolbar button]
  


  
    Double-click the .opf file in the Book Browser window before running PageEdit, if you want to edit or preview all XHTML files with PageEdit. Otherwise, you’ll only be able to access the current XHTML file.

  


  Running PageEdit as a stand-alone application


  Install PageEdit, and create a Desktop shortcut:


  
    Windows


    Open the Windows Explorer, locate PageEdit.exe in the C:\Program Files\PageEdit folder, right-click it, and select Send to Desktop. (You can also add an app shortcut to the Start menu.)


    Mac


    Open a Finder window, locate the PageEdit app in the Applications folder, and drag it to the Desktop.


    Linux


    Since most distributions will automatically add a PageEdit shortcut to the desktop environment, you shouldn’t have to manually create one.

  


  User Interface


  — PageEdit Menus and Toolbars —


  
    [image: a screenshot of the PageEdit window]
  


  PageEdit’s user interface consists of:


  
    	Main Menu: Most of the available commands, like File→Open, are listed here.


    	Toolbar Buttons: Movable buttons that provide quick access to many menu items.


    	Context Menus: Commands shown when you right-click on something.

  


  
    The screenshots in the User Guide may be slightly different to what you see on your computer.

  


  Main Menu


  This is the list of menu items that is always at the top of PageEdit’s window:


  
    [image: a screenshot of the PageEdit main menu]
  


  File


  
    	Open: Open an HTML file from your computer.


    	Save: Save your file (use often!).


    	Save As: Save your file under a different name.


    	Quit: Exit PageEdit, asking if you want to save your file first if it hasn’t been saved.


    	Preferences: Open the Preferences window to change options.


    	About: Display build information.

  


  Edit


  
    	Undo: Restore text just deleted, inserted or replaced.


    	Redo: Reverse the last Undo.


    	Cut: Remove the selected text and store it for paste.


    	Copy: Copy the selected text and store it for paste.


    	Paste: Insert previously cut or copied text into your document.


    	Select All: Select all text in document.

  


  Find


  
    	Find: Open the Find toolbar.


    	Find Next: Search forwards for the next matching text.


    	Find Previous: Search backwards for the next matching text.

  


  Insert


  
    	Split Marker: Insert a marker to use for Split at Markers.


    	Special Character: Insert special characters from a list.


    	Bulleted List: Create a bulleted list from selection.


    	Numbered List: Create a numbered list from selection.

  


  Format


  
    	Heading: 

    
      	Heading 1: Format the paragraph as a level 1 heading.


      	Heading 2: Format the paragraph as a level 2 heading.


      	Heading 3: Format the paragraph as a level 3 heading.


      	Heading 4: Format the paragraph as a level 4 heading.


      	Heading 5: Format the paragraph as a level 5 heading.


      	Heading 6: Format the paragraph as a level 6 heading.


      	Normal: Format the paragraph as normal text.


      	Preserve existing attributes: Keep attributes like class when formatting.

    



    	Align Left: Align text to the left margin (use remove formatting to reset to default).


    	Center: Align text centered on the screen.


    	Align Right: Align text to the right margin.


    	Justify: Align text to left and right margins.


    	Decrease Indent: Decrease the indentation of the text.


    	Increase Indent: Indent the text.

  


  View


  
    	Toolbars 

    
      	File: Show or hide the open and save buttons.


      	Edit: Show or hide the undo, redo, cut and paste buttons.


      	Mode: Show or hide the Mode button.


      	Insert: Show or hide the list, insert split marker and special character buttons.


      	Inspect: Show or hide the Inspect button.


      	Find: Show or hide the Find button.


      	Heading: Show or hide the heading buttons.


      	Format: Show or hide the bold, italic and other formatting buttons.


      	Align: Show or hide the text alignment buttons.


      	Indent: Show or hide the indent buttons.


      	Navigate: Show or hide the Navigate buttons.

    



    	Zoom In: Increase the size of text and images in the view.


    	Zoom Out: Decrease the size of text and images in the view.


    	Zoom Reset: Reset the window zoom to 100%.

  


  Inspector


  
    
      	Inspector: Show the Inspector window.

    

  


  Toolbars


  Toolbars are the rows of buttons at the top of the window. But the buttons don’t have to remain at the top of the screen – you can click and drag groups of buttons anywhere you want.


  
    To move buttons, click and hold on the small bar to the left of each button group then drag it to where you want it.


    Right-click on the toolbar to easily select which buttons to show.

  


  Main Toolbar


  The main toolbar contains buttons used for shortcuts to PageEdit’s main features:


  
    [image: a screenshot of the main PageEdit toolbar]
  


  The buttons are listed below, with their equivalent menu entry:


  File Toolbar


  
    [image: a screenshot of the file toolbar] 

    
      	Open: File→Open


      	Save: File→Save

    

  


  
    Edit Toolbar


    [image: a screenshot of the edit toolbar]


    
      	Undo: Edit→Undo


      	Redo: Edit→Redo


      	Cut: Edit→Cut


      	Copy: Edit→Copy


      	Paste: Edit→Paste


      	Select All: Edit→Select All

    

  


  
    Insert Toolbar


    [image: a screenshot of the insert toolbar]


    
      	Bulleted List: Format→Bulleted List


      	Numbered List:Format→Numbered List


      	Insert Special Character: Insert→Special Character


      	Insert Split Marker: Insert→Split Marker

    


    
      Navigation Toolbar


      [image: a screenshot of the navigation toolbar]


      
        	Navigation list: (no equivalent menu entry)


        	Previous file: (no equivalent menu entry)


        	Next file: (no equivalent menu entry)


        	Return: (no equivalent menu entry)

      

    

  


  Heading Toolbar


  [image: a screenshot of the heading toolbar]


  
    	Heading 1: Format→Heading→Heading 1


    	Heading 2: Format→Heading→Heading 2


    	Heading 3: Format→Heading→Heading 3


    	Heading 4: Format→Heading→Heading 4


    	Heading 5: Format→Heading→Heading 5


    	Heading 6: Format→Heading→Heading 6


    	Normal: Format→Heading→Normal

  


  
    Format Toolbar


    [image: a screenshot of the format toolbar]


    
      	Bold: Format→Bold


      	Italic: Format→Italic


      	Underline: Format→Underline


      	Strikethrough: Format→Strikethrough


      	Subscript: Format→Subscript


      	Superscript: Format→Superscript

    

  


  
    Align Toolbar


    [image: a screenshot of the align toolbar]


    
      	Align Left: Format→Align Left


      	Center: Format→Center


      	Align Right: Format→Align Right


      	Justify: Format→Justify

    

  


  
    Indent Toolbar


    [image: a screenshot of the indent toolbar]


    
      	Decrease Indent: Format→Decrease Indent


      	Increase Indent: Format→Increase Indent

    

  


  
    Find Toolbar


    [image: a screenshot of the find button]

  


  
    	Find: Find→Find

  


  
    Inspector


    [image: a screenshot of the inspector button]


    
      	Inspector: Inspector→Inspector

    

  


  
    Mode (Edit/Preview)


    [image: a screenshot of the mode button][image: a screenshot of the preview button]


    
      	Mode: (no equivalent menu entry)

    

  


  Zoom


  On the lower right of the main window is a zoom control that lets you shrink or enlarge the text and images:


  
    [image: a screenshot of the zoom toolbar]
  


  The 100% indicates the zoom level of the view and this percentage will increase or decrease when you click on the + or – icons.


  Status Bar


  The bottom area on the main window (to the left of the zoom control) will occasionally list status information when an action is completed.


  
    [image: a screenshot of the status bar]
  


  Tooltips


  Many of the buttons, dropdown boxes, labels and fields have tooltips that provide information on how they are used.


  To see a tooltip just hover your mouse over the button or other item and the help text should be displayed:


  
    [image: a screenshot of a tooltip]
  


  
    There are many tooltips available in PageEdit – most dialogs and buttons will provide some help text.

  


  Preferences


  — Customize PageEdit —


  The Preferences dialog gives you control over many settings in PageEdit.


  Select the menu item File→Preferences to open the Preferences dialog:


  You can change the following settings (see below for details):


  
    	Appearance


    	General Settings

  


  Once the Preferences window is open, you can choose the area you want to modify by clicking on the entry on the left. Selecting OK or closing the window will save the current settings.


  Appearance


  
    Appearance settings do not affect how your HTML file is displayed to the user!

  


  You can modify the fonts and colors that PageEdit uses to display your XHTML file while editing:


  
    [image: a screenshot of the appearance dialog]
  


  The settings that can be changed include:


  
    	Preview: You can independently set the font family/size for serif fonts and sans-serif fonts.


    	Insert Special Characters: You can set the font family/size of characters in the Special Characters dialog.

  


  
    The default fonts are Arial and Times New Roman. If these are not available on your system, the preferences will default to the first available font.

  


  
    [image: a screenshot of the icon size slider]
  


  
    	Icon Size: This slider changes the size of the icons in the main menu.

  


  General Settings


  
    [image: a screenshot of the general settings dialog]
  


  The settings that can be changed include:


  
    	User Interface Language: Select the PageEdit user interface language.


    	Spellcheck Dictionary: Select the default spellcheck dictionary.


    	Control Access by HMTL files to non-multimedia remote resources: Enable this option to allow XHTML files to access non-multimedia remote resources.


    	Control use of JavaScript by HMTL files: Enable this option to allow XHTML files to run JavaScript.


    	Handle multiple whitespace layout using: Select the desired whitespace handling option.


    	Use prettify to reformat xhtml when saving: Enable this option to reformat XHTML files when saving.

  


  
    If you change the user interface language, you must restart PageEdit in order for the new user interface language to take effect.


    (If a translation is not available for specific words then they will be shown in English.)

  


  Spellcheck Dictionary


  PageEdit includes several standard dictionaries: US English, British English, French, German and Spanish. You can select one using the Spellcheck Dictionary drop-down menu.


  
    [image: a screenshot of the spellcheck dictionary drop-down box]
  


  
    You can download additional .bdic dictionaries from the Chromium Hunspell website and install them by copying them to the qtwebengine_dictionaries folder.


    For example, if you want to install an Italian dictionary, download it-IT-3-0.bdic and copy it to the qtwebengine_dictionaries folder.


    Advanced users can also convert their Hunspell dictionaries with qwebengine_convert_dict.

  


  
    Open Preferences Location


    The Open Preferences Location button on all the Preferences screens can be used to open the directory containing all of your preference files. You can copy the files for backup or for sharing with others.


    The preferences location will likely be in the following locations:


    Windows:


    %USERPROFILE%\AppData\Local\sigil-ebook\pageedit


    MAC:


    ~/Library/Application\ Support/sigil-ebook/pageedit


    Linux:


    $HOME/.local/share/sigil-ebook/pageedit


    And the files you are likely to see will include:


    
      	pageedit.ini: General configuration information for Sigil.

    

  


  
    If you delete pageedit.ini, PageEdit will reset all preferences.

  


  Change the Font Size Of GUI Controls


  Since PageEdit is a Qt app, you can customize the font size of some GUI controls with a qt_styles.qss style sheet file in the PageEdit preferences folder. (qt_styles.qss needs to contain valid Qt style sheet declarations.)


  For example, the following styles will increase the font size of the fields in the Find toolbar:


  QLabel { font-size: 16pt }
QLineEdit { font-size: 16pt }
QComboBox { font-size: 16pt }



  Opening and Saving Files


  — Load and Save Your HTML Files —


  PageEdit supports opening XHTML files.


  
    Save early, save often, and make backup copies!


    Always close PageEdit before you open your HTML file in another program – or the other program will lock the file and prevent you from saving in PageEdit.

  


  Opening Documents


  To open a file, click the Open button [image: a screenshot of the open button], or select the menu item File→Open or its keyboard shortcut CTRL+O then choose the file you want to open:


  
    HTML Files


    
      	The HTML file and any linked files and stylesheets are imported if possible.


      	If the HTML file is invalid after cleaning, PageEdit will report the error but may not load the file. You may have to fix the errors outside of PageEdit.

    

  


  Saving Documents


  Save your HTML file by clicking the Save button [image: a screenshot of the save button], or selecting the menu item File→Save or its shortcut CTRL+S. (You should always save your document before doing major edits in case you want to undo them.)


  
    If you edit any text in your document, an asterisk ( * ) is added to the file’s name in the titlebar.

  


  When you save your file PageEdit will check it for certain errors and warn you if you need to fix anything.


  
    PageEdit will not always be able to save an HMTL file that contains errors, so frequent saves will make it easier to identify if there are errors that you need to correct.


    PageEdit will also clean your source code according to your preferences when saving the file.

  


  Spellcheck


  — Checking and Correcting Spelling —


  Configure Spellchecking


  PageEdit includes several standard dictionaries: US English, British English, French, German, Spanish. You can select one using the Select Language context menu.


  
    [image: a screenshot of the select language menu]
  


  You can also set the default spellcheck dictionary in the Preferences dialog. Advanced users can also install additional .bdic dictionaries.


  Automatic Spellchecking


  PageEdit will highlight any misspelled words with a wavy red underline when the Check Spelling option is enabled:


  You can then right-click on the misspelled word to bring up a list of choices:


  
    [image: a screenshot of the spellcheck context menu]
  


  
    	Suggested Words: A list of alternative words to choose from—selecting one will replace the misspelled word.


    	Check Spelling: Enable/disable the spellcheck.


    	Select Language: Change the spelling dictionary.

  


  Special Characters


  — Insert Special Characters —


  You can insert characters that might not be on your keyboard into your document using the Special Characters dialog.


  To insert special characters click the Insert Special Character button [image: a screenshot of the insert special character button], or select the menu item Insert→Special Characters.


  
    [image: a screenshot of the insert special character dialog]
  


  The dialog will stay open to allow you to insert text multiple times, and you can move the window to any position on the screen you want.


  
    You can use Ctrl-click to select and insert the character and close the dialog window immediately.

  


  If you pause over a character you will see a tooltip listing the HTML entity code for the character and a description:


  
    [image: a screenshot of a tooltip]
  


  You can change the font and size of the characters in the dialog using Preferences.


  Some characters may not display correctly in some fonts.


  Inserting Split Markers


  — For use with Sigil —


  You can use PageEdit’s Split Marker function to insert Sigil split markers. Split markers are special <hr> tags with sigil_split_marker class attributes, which are shown as thin lines in PageEdit. For more information on split markers, see the Sigil User Guide.


  You can insert a split marker at your cursor position immediately by clicking the Split At Cursor button [image: a screenshot of the insert split marker button] or selecting the menu item Insert→Split Marker. (You can also press its keyboard shortcut CTRL+SHIFT+ENTER.)


  Simply click in your document exactly where you want the split marker to be inserted, e.g. at the beginning of a chapter name:


  
    [image: a screenshot of the file without the split marker]
  


  Then click [image: a screenshot of the insert split marker button] to insert a Sigil split marker:


  
    [image: a screenshot of a file with the split marker]
  


  
    Save your HTML file before inserting split markers!

  


  Find


  — Searching In PageEdit —


  Finding text and updating it is one of the most common tasks in PageEdit—to look for words, to remove unwanted text, or to change the formatting of specific items.


  To display the Find toolbar, select the menu item Find→Find or press its keyboard shortcut CTRL+F:


  
    [image: a screenshot of the find toolbar]
  


  Actions


  The buttons on the right are used to run your search commands.


  
    	Down Arrow: Finds the next occurrence of your search term.


    	Up Arrow: Finds the previous occurrence of your search term.


    	Match Case: If enabled, PageEdit will search for exactly what you type.

  


  Edit and Preview modes


  — Toggling between Edit and Preview modes —


  PageEdit has two modes: Edit and Preview. You can toggle between these two modes by clicking the Mode button:


  
    [image: a screenshot of the edit button][image: a screenshot of the preview button]
  


  The active mode is also indicated in the title bar:


  
    [image: preview_mode]
  


  Note that you’ll need to activate the preview mode, if you want to test links to other XHTML files.


  
    Double-click the .opf file in the Sigil Book Browser window before running PageEdit, if you want to edit or preview all XHTML files or test links to other files.

  


  Using the Inspector


  — Examine and modify HMTL code —


  Advanced users can use the Inspector window to examine and modify HTML code. For more information, see the Chrome DevTools website.


  Contributing to PageEdit


  — Helping Development —


  PageEdit is completely free and open-source software, and it is developed and supported entirely by volunteers who love books and want well-edited ebooks to be easily available. Your entirely optional contributions can help improve PageEdit and show your appreciation for making the software available. Feel free to just say hi on the PageEdit forum and let others know how useful PageEdit is to you.


  Translating PageEdit


  Translating PageEdit into other languages is highly encouraged. There is an active community of volunteers who translate PageEdit already, and new languages can always be added.


  The best way to translate PageEdit is to use the web based translation system provided by Transifex. Translations done using Transifex are downloaded just before releasing a new version:


  
    	PageEdit translations @ Transifex

  


  Alternatively you can use local Desktop tools for translation. PageEdit uses Qt’s Linguist tool for creating and editing translations. You can either download Qt and compile the tools manually or use the pre-built packages:


  
    	Pre-built Translation tools

  


  Updating and creating new translation files using the Desktop tools is the same process:


  
    	Open a terminal and change to the src/PageEdit/Resource_Files/ts directory. This holds all the raw translation files.


    	Run lupdate ../../ * -ts out.ts to either generate a new translation file or to update an existing one with any new strings that have been added.


    	Use Linguist to write translations for the strings in a given ts file.

  


  All translations files should have the form base_pageedit_lang.ts. Where lang is a two letter language code. For example the Polish translation will have the file name base_pageedit_pl.ts.


  Assisting Users


  If you are an experienced PageEdit user, HTML expert, or working your way there, you can help by answering questions or commenting on your experiences – primarily at the official PageEdit Forum at MobileRead. You can also check issues on the development website and add comments.


  Coding


  If you are a C++ programmer and have suggestions for improvements or bug fixes you are welcome to submit patches for consideration.
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